2

I recently answered a question, and I wanted to add notation to provide a better explanation.

I'm not yet as experienced as I'd like to, but I tested the code both in the sandbox and in the "official" editor, and they did look fine. After some changes, I did begin to face some strange issues. I tried to fix them, and I also faced unexpected and unreliable behavior (even when trying with private mode and after clearing the cache).

So, the code is in three parts (one for each example):

First example

X: 0
K: C
L: 1/4
_B, C _D _E F G A _B
C _D _E F G A _B c

Second example

X: 1
K: C
L: 1/4
_G _A __B _c _d _e f _g
_A __B _c _d _e f _g _a

Third example

X: 2
K: C
L: 1/4
^G A B ^c ^d ^e ^f ^g
A B ^c ^d ^e ^f ^g a

At the time of writing, I really don't know how this would result but I can provide screenshots of what I'm getting on my browsers. What puzzles me is that I get "wrong" result in newer (but not so-updated) browsers than in olders.

Chrome (very old, version 46.0.2490.71):

chrome screenshot

Chromium (pretty old, version 59.0.3071.104):

chromium screenshot

Firefox (slightly old, version 78.0), similar to Chromium:

firefox screenshot

An interesting aspect is that with both Chromium and Firefox I can see, for an instant, the tab visualization.

I know that I'm not using the latest versions of any of those browsers (for technical problems, I cannot upgrade them right now), but I'm not sure about the source of the issue. I don't know if it's a cache issue, caused by my previous editing attempts (but I cannot absolutely be certain about it), as it took me a while to get the example as I wanted, but I'm also worried about people who cannot, for any valid reason, install a "recent" version of the browser.

4
  • 2
  • If you press CTRL+F5 (Windows) or CMD+SHIFT+R (Mac), it will display correctly (until the next time you visit the post).
    – Aaron
    Aug 6 at 5:12
  • @Aaron thanks for the other question, it seems a similar problem, but, as said, clearing/ignoring the cache doesn't solve the problem at least on Firefox (interestingly enough, I can see it properly rendered on Chromium today). I also tried in private mode, with another profile, and by bypassing the cache with the browser console without seeing any difference, similarly to what some pointed out in the related post (so, technically it could be a duplicate, but it doesn't really answer the question). Aug 6 at 17:47
  • You are not the first person to have or indeed report this problem, but a hard refresh has so fae always solved the problem for folks that have had it
    – AakashM
    Sep 13 at 15:15

You must log in to answer this question.

Browse other questions tagged .